Control Web Panel (CWP) before webpanel_version 1.16 contains an OS command injection vulnerability in the
Source GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 1.16 as a priority.
Data as of 2 Nov 2026, 19:30 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 1.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Control Web Panel to 1.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Control Web PanelControl Web Panel | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the user panel module and monitor for suspicious activity related to the acc=deletedp action. Avoid exposing the affected functionality to untrusted users.
Description
Control Web Panel (CWP) versions before 1.16 contain an OS command injection vulnerability in the protected_directory user panel module. This flaw allows attackers to execute arbitrary operating system commands by submitting unescaped input via the file POST parameter in the acc=deletedp action. The vulnerability arises because attacker-controlled input is passed directly into a shell_exec call, enabling code execution within the user panel context.