Control Web Panel (CWP) before webpanel_version 1.30 contains an OS command injection vulnerability in the loopback
Source GCVE Database
Not known to be exploited · CVSS 8.6 High : upgrade to 1.30 soon.
Data as of 2 Nov 2026, 19:29 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.6 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 8.4 |
- Patch
- Available – fixed in 1.30
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade Control Web Panel to 1.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Control Web PanelControl Web Panel | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the /v1/restoredatabase/ endpoint to trusted users only and monitor for suspicious activity. Avoid exposing this API to untrusted networks.
Description
Control Web Panel (CWP) versions before 1.30 contain an OS command injection vulnerability in the loopback API database restore route (/v1/restoredatabase/). The vulnerability arises because the restoreDBBackup() handler passes an attacker-controlled file path from the POST body directly into a shell command without proper escaping. An attacker who can access this route can execute arbitrary OS commands with root privileges.