Skip to main content
CVE-2024-33893VulnerabilityPublished Updated

Cosy+ devices running a firmware 21.x below 21.2s10 or a firmware 22.x below 22.1s3 are vulnerable to XSS when

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-33893· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium · fixed in 22.1s3 : update affected systems when convenient.

Data as of 3 Nov 2026, 17:23 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 22.1s3, 21.2s10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Aug 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

AI-suggested

Upgrade affected Cosy+ devices to firmware version 21.2s10 or later if running 21.x, or to version 22.1s3 or later if running 22.x. These versions contain the official fix for the XSS vulnerability. No other mitigation steps are indicated.

Description

Cosy+ devices with firmware versions 21.x prior to 21.2s10 and 22.x prior to 22.1s3 are vulnerable to a cross-site scripting (XSS) flaw due to improper input sanitization when displaying logs. This vulnerability allows an attacker to execute malicious scripts in the context of the affected device's web interface. The issue is resolved in firmware versions 21.2s10 and 22.1s3.

References

Community reviews

Loading reviews…