Skip to main content
CVE-2025-54988VulnerabilityPublished Updated

Apache Tika (tika-parser-pdf-module) · Critical XXE

Affects tikaSource GCVE Database

0
Compare
Authoritative record:CVE-2025-54988· High 8.4

Not known to be exploited · public detection template (Nuclei) · 47% EPSS · CVSS 8.4 High · fixed in 1.22-1ubuntu0.1~esm2 : patch tika soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
47.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.22-1ubuntu0.1~esm2, 1.22-2+deb11u1build0.22.04.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Aug 2025

  2. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade the Ubuntu tika to 1.22-1ubuntu0.1~esm2 (package) or 1.22-2+deb11u1build0.22.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10tikapkg:deb/ubuntu/tika?arch=source&distro=stonkingOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 26.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=resoluteOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 25.10tikapkg:deb/ubuntu/tika?arch=source&distro=questingOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 24.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=nobleOther threatsAffected
  • =1.22-2
Fixed in–
Ubuntu 22.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=jammyOther threatsAffected
  • <1.22-2+deb11u1build0.22.04.1
Fixed in
  • 1.22-2+deb11u1build0.22.04.1
Ubuntu Pro 20.04 LTStikapkg:deb/ubuntu/tika?arch=source&distro=esm-apps/focalOther threatsAffected
  • <1.22-1ubuntu0.1~esm2
Fixed in
  • 1.22-1ubuntu0.1~esm2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade Apache Tika to version 3.2.2 or later. For Ubuntu users, update to package versions 1.22-1ubuntu0.1~esm2 or 1.22-2+deb11u1build0.22.04.1 as provided in the Ubuntu security notice USN-8324-1. Applying these updates will remediate the vulnerability. Standard system updates on supported Ubuntu releases will include these fixes. No additional mitigation is required beyond applying the official patches.

Description

A critical XML External Entity (XXE) vulnerability exists in Apache Tika's tika-parser-pdf-module versions 1.13 through 3.2.1. This flaw allows attackers to exploit crafted XFA files inside PDFs to read sensitive data or send malicious requests to internal or external servers. The vulnerability affects multiple Tika packages that depend on this module. Fixed versions are available, and users are advised to upgrade to version 3.2.2 or the patched Ubuntu package versions.

References

Community reviews

Loading reviews…