Skip to main content
CVE-2021-4297VulnerabilityPublished Updated

CVE-2021-4297: trampgeek jobe · Privilege Escalation

Affects trampgeek jobeSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jan 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHubtrampgeek/jobepkg:github/trampgeek/jobeOther threatsAffected
  • <=1.6.4
  • =1.6.0
  • =1.6.1
  • =1.6.2
  • =1.6.3
  • =1.6.4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should prioritize upgrading trampgeek jobe to version 1.6.5 or later, where the vulnerability is patched. In addition to patching, organizations should implement strict network segmentation to limit adjacent network access to the application, reducing the attack surface. Access controls should be reviewed and tightened to ensure that users have the minimum necessary privileges, limiting the potential impact of privilege escalation. Monitoring and logging of access to the runs_post function and related API endpoints should be enhanced to detect anomalous activity indicative of exploitation attempts. Conducting regular security audits and code reviews of custom integrations with trampgeek jobe can help identify and remediate similar privilege management issues. Finally, organizations should ensure that internal users and administrators are trained to recognize and report suspicious behavior that could indicate exploitation attempts.

Description

A vulnerability has been found in trampgeek jobe up to 1.6.4 and classified as problematic. This vulnerability affects the function runs_post of the file application/controllers/Restapi.php. The manipulation of the argument sourcefilename leads to an unknown weakness. Upgrading to version 1.6.5 is able to address this issue. The patch is identified as 694da5013dbecc8d30dd83e2a83e78faadf93771. It is recommended to upgrade the affected component. VDB-217174 is the identifier assigned to this vulnerability.

References

Community reviews

Loading reviews…