Skip to main content
VulnerabilityPublished Updated

CVE-2023-2252: Directorist (WordPress plugin) · Path Traversal

Affects Directorist (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 2.7 Low · fixed in 7.5.4 : update Directorist (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
2.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5.4
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2024

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Unknown DirectoristAffected
  • =0
Fixed in–

AI-suggested

European organizations should ensure that all WordPress plugins, including Directorist, are updated to the latest version (7.5.4 or later) where this vulnerability is patched. Access controls should be strictly enforced to limit administrative privileges only to trusted users, reducing the risk of exploitation by malicious insiders or compromised accounts. Implementing Web Application Firewalls (WAFs) with rules to detect and block path traversal attempts can provide an additional layer of defense. Regular security audits and monitoring of file access logs can help detect suspicious activity related to file inclusion attempts. Finally, organizations should consider isolating WordPress environments and sensitive files to minimize the impact of any potential LFI vulnerabilities.

Description

The Directorist WordPress plugin before 7.5.4 is vulnerable to Local File Inclusion as it does not validate the file parameter when importing CSV files.

References

Community reviews

Loading reviews…