CVE-2023-2610: vim/vim · Integer Overflow or Wraparound
Affects vim/vimSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 9.0.1532 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.1532
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 May 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade vim/vim to 9.0.1532.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubvim/vimpkg:github/vim/vimOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately verify the versions of Vim deployed across their environments and upgrade to version 9.0.1532 or later where the vulnerability is fixed. Since no direct patch links are provided, users should obtain updates from official Vim repositories or trusted Linux distribution package managers. Additionally, organizations should implement strict file handling policies to avoid opening untrusted or suspicious files with Vim, especially from external sources. Employing endpoint protection solutions that monitor for unusual local file access or editor behavior can help detect exploitation attempts. User training to recognize phishing or malicious file delivery vectors is also critical. For environments where Vim is used with elevated privileges, consider restricting its use or employing sandboxing techniques to limit the impact of potential exploitation. Regular vulnerability scanning and configuration management should include checks for vulnerable Vim versions. Finally, monitoring logs for crashes or anomalous behavior in Vim instances can provide early warning signs of exploitation attempts.
Description
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1532.
References
- huntr.dev/bounties/31e67340-935b-4f6c-a923-f7246bc29c7d (opens in a new tab)
- github.com/vim/vim/commit/ab9a2d884b3a4abe319606ea95a5a6d6b01cd73a (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PCLJN4QINITA3ZASKLEJ64C5TFNKELMO/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2023/06/msg00015.html (opens in a new tab)
- support.apple.com/kb/HT213844 (opens in a new tab)
- support.apple.com/kb/HT213845 (opens in a new tab)
- security.netapp.com/advisory/ntap-20241129-0006/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00023.html (opens in a new tab)