CVE-2023-43208: NextGen Healthcare Mirth Connect · OS Command Injection
Affects NextGen Healthcare Mirth ConnectSource CVE Database V5
Mentioned vulnerabilities
Exploited in the wild · used in ransomware campaigns · KEV due 10 Jun 2024 · public exploit available (Metasploit) · 82% EPSS : upgrade to 4.4.1 now.
Data as of 26 Oct 2026, 11:42 UTC
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else.
- Ransomware
- Used in ransomware campaigns
- EPSS
- 82.7% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 26 Oct 2023
Detectable: evidence found.
nuclei template: NextGen Healthcare Mirth Connect - Remote Code Execution
Weaponised: evidence found.
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 207 days after disclosure
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by MITRE Corporation
, 38 days before disclosure
CVE published
on cve.org
, t = 0
Added to CISA KEV (opens in a new tab)
exploitation confirmed · ransomware use known
, 207 days after disclosure
KEV remediation due
US federal deadline
, 228 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade com.nextgenhealthcare/mirth-connect to 4.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavencom.nextgenhealthcare/mirth-connectpkg:maven/com.nextgenhealthcare/mirth-connectOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
NextGen Healthcare Mirth Connect before version 4.4.1 is vulnerable to unauthenticated remote code execution. Note that this vulnerability is caused by the incomplete patch of CVE-2023-37679.
References
- horizon3.ai/nextgen-mirth-connect-remote-code-execution-vulnerability-cve-2023-43208/ (opens in a new tab)
- packetstormsecurity.com/files/176920/Mirth-Connect-4.4.0-Remote-Command-Execution.html (opens in a new tab)
- cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-43208 (opens in a new tab)