CVE-2023-44312: Apache ServiceComb Service-Center · Information Exposure
Affects Apache ServiceComb Service-CenterSource CVE Database V5
Not known to be exploited · CVSS 5.8 Medium : upgrade to 2.2.0 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Apache ServiceComb Service-Center to 2.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache ServiceComb Service-Center | Affected
| Fixed in
|
AI-suggested
European organizations should prioritize upgrading Apache ServiceComb Service-Center to version 2.2.0 or later to remediate this vulnerability. Beyond patching, organizations should implement strict network segmentation and firewall rules to restrict access to the Service-Center management interfaces, ensuring they are not exposed to public or untrusted networks. Employing strong authentication and authorization mechanisms around service governance tools can further reduce risk. Regularly auditing access logs and monitoring for unusual access patterns to the Service-Center can help detect potential exploitation attempts early. Additionally, organizations should review and minimize the sensitive information stored or accessible via Service-Center to reduce the impact of any potential leaks. Incorporating these controls into a broader microservices security strategy will enhance resilience against similar vulnerabilities.
Description
Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects Apache ServiceComb Service-Center before 2.1.0 (include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.