CVE-2023-45648: Apache Tomcat · Improper Input Validation
Affects Apache TomcatSource CVE Database V5
Exposed hosts seen by OffSeq Mirage · public detection template (Nuclei) · CVSS 5.3 Medium · fixed in 10.1.14 : update Apache Tomcat when convenient.
Data as of 26 Oct 2026, 11:42 UTC
- EPSS
- 5.8% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.1.14, 9.0.81, 8.5.94
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Oct 2023
Detectable: evidence found.
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: evidence found.
9 exposed hosts found; no attack traffic recorded
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.tomcat/tomcat to 10.1.14, 9.0.81 or 8.5.94.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading Apache Tomcat to the fixed versions: 8.5.94 or later, 9.0.81 or later, 10.1.14 or later, or 11.0.0-M12 or later. Where immediate upgrade is not feasible, organizations should implement strict input validation and filtering at the reverse proxy or web application firewall level to detect and block malformed HTTP trailer headers. Reviewing and hardening reverse proxy configurations to ensure consistent HTTP parsing behavior between front-end and backend servers can reduce risk. Monitoring HTTP traffic for anomalies indicative of request smuggling attempts is advised. Additionally, organizations should audit their infrastructure to identify all Tomcat instances, including legacy and development environments, to ensure comprehensive patching. Employing layered security controls such as network segmentation and strict access controls around Tomcat servers can limit potential impact. Finally, maintaining up-to-date threat intelligence feeds and monitoring vendor advisories will help detect emerging exploit attempts.
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
References
- lists.apache.org/thread/2pv8yz1pyp088tsxfb7ogltk9msk0jdp (opens in a new tab)
- openwall.com/lists/oss-security/2023/10/10/10 (opens in a new tab)
- debian.org/security/2023/dsa-5522 (opens in a new tab)
- debian.org/security/2023/dsa-5521 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2023/10/msg00020.html (opens in a new tab)
- security.netapp.com/advisory/ntap-20231103-0007/ (opens in a new tab)