CVE-2023-4738: vim/vim · Heap-based Buffer Overflow
Affects vim/vimSource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 9.0.1848 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.1848
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Sep 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vim/vim to 9.0.1848.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubvim/vimpkg:github/vim/vimOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2023-4738, European organizations should: 1) Immediately update vim to version 9.0.1848 or later where the vulnerability is patched. 2) Verify that all Unix/Linux systems, including servers, workstations, and containers, use the updated vim version by auditing installed packages and software inventories. 3) Restrict local access to trusted users only, minimizing the risk of exploitation by unauthorized personnel. 4) Implement strict user privilege management to limit the impact of any successful exploitation, ensuring users run vim with the least privileges necessary. 5) Monitor systems for unusual activity related to vim usage, such as unexpected crashes or anomalous process behavior. 6) Educate users about the risks of opening untrusted files or executing unknown scripts within vim. 7) For environments where updating vim immediately is not feasible, consider temporarily restricting vim usage or replacing it with alternative editors not affected by this vulnerability. 8) Collaborate with Linux distribution maintainers or software vendors to ensure timely patch deployment. 9) Incorporate this vulnerability into vulnerability management and incident response plans to ensure rapid detection and remediation if exploitation attempts occur.
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1848.
References
- huntr.dev/bounties/9fc7dced-a7bb-4479-9718-f956df20f612 (opens in a new tab)
- github.com/vim/vim/commit/ced2c7394aafdc90fb7845e09b3a3fee23d48cb1 (opens in a new tab)
- support.apple.com/kb/HT213984 (opens in a new tab)
- seclists.org/fulldisclosure/2023/Oct/24 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/03/msg00023.html (opens in a new tab)