CVE-2023-50854: Squirrly SEO (WordPress plugin) · SQL Injection
Affects Squirrly SEO (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 2.4.02 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.02
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 28 Dec 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Squirrly SEO (WordPress plugin) to 2.4.02.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Squirrly Squirrly SEO - Advanced Pack | Affected
| Fixed in
|
AI-suggested
European organizations should immediately audit their WordPress installations to identify if the Squirrly SEO - Advanced Pack plugin is installed and determine the version in use. If you cannot patch yet, organizations should consider the following specific mitigations: 1) Restrict administrative access to trusted personnel only and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of privilege escalation. 2) Employ Web Application Firewalls (WAFs) with custom rules to detect and block SQL injection patterns targeting this plugin. 3) Conduct thorough code reviews and consider temporarily disabling or uninstalling the plugin if it is not critical to business operations. 4) Monitor logs for unusual database queries or access patterns that could indicate exploitation attempts. 6) Implement database least privilege principles, ensuring the WordPress database user has only necessary permissions to limit the impact of SQL injection. These measures go beyond generic advice by focusing on privilege management, monitoring, and proactive plugin management tailored to this vulnerability.
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Squirrly Squirrly SEO - Advanced Pack.This issue affects Squirrly SEO - Advanced Pack: from n/a before 2.4.02.