Skip to main content
CVE-2024-10002VulnerabilityPublished Updated

CVE-2024-10002: Rover IDX (WordPress plugin) · Authentication Bypass Using an Alternate Path or Channel

Affects Rover IDX (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 3.0.0.2905 : patch Rover IDX (WordPress plugin) soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.0.2905
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
stevemullen Rover IDXAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade the Rover IDX plugin to version 3.0.0.2906 or later, where the vulnerability is fully patched. Version 3.0.0.2905 includes a partial fix but does not completely resolve the issue. No other mitigations are indicated by the vendor advisory. Patch status is confirmed by the versioning information in the description.

Description

The Rover IDX plugin for WordPress is vulnerable to Authentication Bypass in versions up to, and including, 3.0.0.2905. This is due to insufficient validation and capability check on the 'rover_idx_refresh_social_callback' function. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to log in to administrator. The vulnerability is partially patched in version 3.0.0.2905 and fully patched in version 3.0.0.2906.

References

Community reviews

Loading reviews…