Skip to main content
VulnerabilityPublished Updated

CVE-2024-10628: Quiz Maker Business (WordPress plugin) · SQL Injection

Affects Quiz Maker Business (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.5 High.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
AYS Pro Plugins Quiz Maker BusinessAffected
  • =7.0.0
Fixed in–

AI-suggested

Organizations should immediately verify the installed versions of the AYS Pro Plugins Quiz Maker Business, Developer, and Agency plugins and upgrade to versions beyond 8.8.0 (Business), 21.8.0 (Developer), or 31.8.0 (Agency) where the vulnerability is patched. If updates are not yet available, consider temporarily disabling the affected plugins or restricting access to the vulnerable endpoints via web application firewalls (WAFs) with custom rules blocking suspicious 'id' parameter inputs. Employ input validation and sanitization at the application level to reject unexpected characters in parameters. Monitor web server logs for unusual query patterns indicative of SQL injection attempts. Implement database user permissions with least privilege to limit data exposure in case of exploitation. Regularly audit and scan WordPress sites using security plugins that detect SQL injection vulnerabilities. Educate site administrators about the shared plugin slug issue to avoid false positives and ensure proper patch verification. Finally, maintain regular backups to enable recovery if a breach occurs.

Description

The Quiz Maker Business, Developer, and Agency plugins for WordPress is vulnerable to SQL Injection via the ‘id’ parameter in all versions up to, and including, 8.8.0 (Business), up to, and including, 21.8.0 (Developer), and up to, and including, 31.8.0 (Agency) due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. NOTE: The three variations of this software (Business, Developer, and Agency) share the same plugin slug, so you may get an alert even if you are running the latest version of any of the pieces of software. In these cases it is safe to dismiss the notice once you've confirmed your site is on a patched version of the applicable software.

References

Community reviews

Loading reviews…