Skip to main content
VulnerabilityPublished Updated

CVE-2024-12421: Coupon Affiliates (WordPress plugin) · Code Injection

Affects Coupon Affiliates (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 5.16.7.1 : update Coupon Affiliates (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.16.7.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
elliotvs Coupon Affiliates – Affiliate Plugin for WooCommerceAffected
  • =0
Fixed in–

AI-suggested

Users should update the Coupon Affiliates – Affiliate Plugin for WooCommerce to version 5.16.7.2 or later to remediate the arbitrary shortcode execution vulnerability. The reflected XSS vulnerability was already fixed in version 5.16.7.1. No other mitigations are indicated by the vendor advisory.

Description

The The Coupon Affiliates – Affiliate Plugin for WooCommerce plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 5.16.7.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. This functionality is also vulnerable to Reflected Cross-Site Scripting. The Cross-Site Scripting was patched in version 5.16.7.1, while the arbitrary shortcode execution was patched in 5.16.7.2.

References

Community reviews

Loading reviews…