Skip to main content
VulnerabilityPublished Updated

CVE-2024-12583: Dynamics 365 Integration (WordPress plugin) · Template Injection

Affects Dynamics 365 Integration (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 9.9 Critical · patch available : patch Dynamics 365 Integration (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
alexacrm Dynamics 365 IntegrationAffected
  • =0
Fixed in–

AI-suggested

A patch is available for this vulnerability. Users of the Dynamics 365 Integration plugin for WordPress should apply the official update to a fixed version beyond 1.3.23 as soon as possible to remediate the issue. Until patched, restrict Contributor-level access to trusted users only.

Description

The Dynamics 365 Integration plugin for WordPress is vulnerable to Remote Code Execution and Arbitrary File Read in all versions up to, and including, 1.3.23 via Twig Server-Side Template Injection. This is due to missing input validation and sanitization on the render function. This makes it possible for authenticated attackers, with Contributor-level access and above, to execute code on the server.

References

Community reviews

Loading reviews…