CVE-2024-13088: QNAP Systems QuRouter · CWE-287
Affects QNAP Systems QuRouterSource CVE Database V5
Not known to be exploited · CVSS 5.2 Medium : upgrade to 2.6.0 or 2.5.0.140 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.0, 2.5.0.140
CVSS:4.0/AV:P/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade QNAP Systems QuRouter to 2.6.0 or 2.5.0.140.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| QNAP Systems Inc. QuRouter | Affected
| Fixed in
|
AI-suggested
Upgrade affected QuRouter devices to version 2.5.0.140 or later, where the vulnerability has been fixed. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-13088 is an improper authentication vulnerability in QNAP Systems Inc. QuRouter that allows an attacker with local network access to compromise system security. The issue affects QuRouter versions 2.5.x and was fixed in version 2.5.0.140 and later. The vulnerability has a medium severity rating with a CVSS 4.0 score of 5.