Skip to main content
CVE-2024-13359VulnerabilityPublished Updated

CVE-2024-13359: Product Input Fields for WooCommerce (WordPress plugin) · Unrestricted File Upload

Affects Product Input Fields for WooCommerce (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High · fixed in 1.12.1 : patch Product Input Fields for WooCommerce (WordPress plugin) soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
tychesoftwares Product Input Fields for WooCommerceAffected
  • =0
Fixed in–

AI-suggested

Upgrade to version 1.12.1 or later, which is confirmed to fully patch this vulnerability. Administrators should ensure the accepted file extensions field is not left blank to prevent direct .php file uploads. Monitor vendor communications for any additional guidance.

Description

The Product Input Fields for WooCommerce plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the add_product_input_fields_to_order_item_meta() function in all versions up to, and including, 1.12.0. This may make it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that by default the plugin is only vulnerable to a double extension file upload attack, unless an administrators leaves the accepted file extensions field blank which can make .php file uploads possible. Please note 1.12.2 was mistakenly marked as patched while 1.12.1 was marked as vulnerable for a short period of time, this is not the case and 1.12.1 is fully patched.

References

Community reviews

Loading reviews…