CVE-2024-21672: Atlassian Confluence Data Center · Remote Code Execution
Affects Atlassian Confluence Data CenterSource CVE Database V5
Not known to be exploited · CVSS 8.3 High · fixed in 8.7.2 : patch Atlassian Confluence Data Center soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.7.2, 8.5.5, 7.19.18
CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade com.atlassian.confluence/confluence-data-center-server to 8.7.2, 8.5.5 or 7.19.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavencom.atlassian.confluence/confluence-data-center-serverpkg:maven/com.atlassian.confluence/confluence-data-center-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize immediate patching by upgrading Confluence Data Center and Server instances to the fixed versions specified by Atlassian (7.19.18+, 8.5.5+, or 8.7.2+). If immediate upgrading is not feasible, organizations should implement compensating controls such as restricting network access to Confluence servers to trusted IP addresses, employing web application firewalls (WAFs) with rules designed to detect and block exploitation attempts targeting this vulnerability, and enhancing monitoring for unusual activity or indicators of compromise related to Confluence. Additionally, organizations should conduct user awareness training to reduce the risk of social engineering attacks that could trigger the required user interaction. Regular backups and incident response plans should be reviewed and tested to ensure rapid recovery in case of exploitation. Network segmentation to isolate Confluence servers from critical infrastructure can limit potential lateral movement. Finally, organizations should subscribe to threat intelligence feeds and Atlassian security advisories to stay informed about any emerging exploit activity.
Description
This High severity Remote Code Execution (RCE) vulnerability was introduced in version 2.1.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.3 and a CVSS Vector of CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H allows an unauthenticated attacker to remotely expose assets in your environment susceptible to exploitation which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives).