CVE-2024-21673: Atlassian Confluence Data Center · Remote Code Execution
Affects Atlassian Confluence Data CenterSource CVE Database V5
Not known to be exploited · CVSS 8.0 High.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavencom.atlassian.confluence/confluencepkg:maven/com.atlassian.confluence/confluenceOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize immediate patching of Confluence Data Center and Server instances by upgrading to the recommended fixed versions: 7.19.18 or later, 8.5.5 or later, or 8.7.2 or later. If immediate patching is not feasible, organizations should implement strict access controls to limit administrative privileges to trusted personnel only and enforce multi-factor authentication (MFA) for all Confluence accounts with elevated privileges to reduce the risk of credential compromise. Network segmentation should be employed to isolate Confluence servers from critical infrastructure and sensitive data repositories. Monitoring and logging of Confluence access and administrative actions should be enhanced to detect anomalous behavior indicative of exploitation attempts. Additionally, organizations should review and harden their Confluence configurations, disable unnecessary plugins or integrations, and regularly audit user permissions. Incident response plans should be updated to include scenarios involving Confluence compromise. Finally, organizations should consider deploying web application firewalls (WAFs) with rules tuned to detect and block suspicious requests targeting Confluence vulnerabilities.
Description
This High severity Remote Code Execution (RCE) vulnerability was introduced in versions 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.0 and a CVSS Vector of CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H allows an authenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, high impact to integrity, high impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).