Skip to main content
VulnerabilityPublished

CVE-2024-2323: WSO2 Enterprise Integrator · Improper Restriction of Excessive Authentication Attempts

Affects WSO2 Enterprise IntegratorSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium : upgrade to 6.6.0.204 when convenient.

Data as of 26 Oct 2026, 14:18 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6.0.204, 7.0.0.35, 6.1.0.150 +15
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 Enterprise IntegratorAffected
  • >=6.6.0 <6.6.0.204
Fixed in
  • 6.6.0.204
WSO2WSO2 Identity ServerAffected
  • >=7.0.0 <7.0.0.35
Fixed in
  • 7.0.0.35
WSO2WSO2 Identity ServerAffected
  • >=6.1.0 <6.1.0.150
Fixed in
  • 6.1.0.150
WSO2WSO2 Identity ServerAffected
  • >=6.0.0 <6.0.0.188
Fixed in
  • 6.0.0.188
WSO2WSO2 Identity ServerAffected
  • >=5.11.0 <5.11.0.344
Fixed in
  • 5.11.0.344
WSO2WSO2 Identity ServerAffected
  • >=5.10.0 <5.10.0.286
Fixed in
  • 5.10.0.286

AI-suggested

If you cannot patch yet, organizations should consider enforcing strong password policies and monitoring for unusual password change attempts.

Description

The RemoteUserStoreManagerService does not sufficiently validate password change attempts when the password history validation feature is enabled. This oversight allows an attacker to repeatedly attempt password guesses for a user account without being adequately restricted. Exploiting this vulnerability enables an attacker to discover a user's password through brute force, leading to account impersonation. The success rate of such an attack is influenced by the complexity of the targeted user's password, with simpler passwords increasing the likelihood of compromise.

References

Community reviews

Loading reviews…