Skip to main content
VulnerabilityPublished Updated

CVE-2024-4457: WSO2 Enterprise Integrator · OS Command Injection

Affects WSO2 Enterprise IntegratorSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 6.6.0.204 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6.0.204, 4.3.0.21, 4.2.0.107 +25
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
WSO2WSO2 Enterprise IntegratorAffected
  • >=6.6.0 <6.6.0.204
Fixed in
  • 6.6.0.204
WSO2WSO2 API ManagerAffected
  • >=4.3.0 <4.3.0.21
Fixed in
  • 4.3.0.21
WSO2WSO2 API ManagerAffected
  • >=4.2.0 <4.2.0.107
Fixed in
  • 4.2.0.107
WSO2WSO2 API ManagerAffected
  • >=4.1.0 <4.1.0.170
Fixed in
  • 4.1.0.170
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.308
Fixed in
  • 4.0.0.308
WSO2WSO2 API ManagerAffected
  • >=3.2.1 <3.2.1.19
Fixed in
  • 3.2.1.19

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available for all affected release lines, including 6.6.0.204, 4.3.0.21, 4.2.0.107, 4.1.0.170, 4.0.0.308, 3.2.1.19, 3.2.0.365, 3.1.0.275, 2.0.0.325, and 2.0.0.345. Users should upgrade to these fixed versions to remediate the vulnerability. No alternative mitigations or temporary fixes are indicated. No known exploits in the wild have been reported, but timely patching is strongly recommended.

Description

CVE-2024-4457 is a critical OS command injection vulnerability in WSO2 Enterprise Integrator's Management Console. It arises from improper validation of input related to JDBC user store configuration, allowing attackers to execute arbitrary code on the server with WSO2 product privileges. This can lead to full system compromise. The vulnerability affects multiple versions prior to specific fixed releases. A high-severity CVSS score of 9.1 reflects the potential impact. Fixed versions are available, and no known exploits are reported in the wild.

References

Community reviews

Loading reviews…