CVE-2024-23682: ares · Trust Boundary Violation
Affects aresSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 1.8.0 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade de.ls1intum/ares to 1.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavende.ls1intum/arespkg:maven/de.ls1intum/aresOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, avoid running untrusted code in the Artemis Java Test Sandbox or restrict usage to trusted users only.
Description
Artemis Java Test Sandbox versions before 1.8.0 are vulnerable to a sandbox escape when an attacker includes class files in a package that Ares trusts. An attacker can abuse this issue to execute arbitrary Java when a victim executes the supposedly sandboxed code.
References
- github.com/ls1intum/Ares/security/advisories/GHSA-227w-wv4j-67h4 (opens in a new tab)
- github.com/ls1intum/Ares/issues/15 (opens in a new tab)
- github.com/ls1intum/Ares/releases/tag/1.8.0 (opens in a new tab)
- github.com/advisories/GHSA-227w-wv4j-67h4 (opens in a new tab)
- vulncheck.com/advisories/vc-advisory-GHSA-227w-wv4j-67h4 (opens in a new tab)