Skip to main content
CVE-2024-23782VulnerabilityPublished Updated

CVE-2024-23782: appleple a-blog cms Ver.3.1.x series · Cross-site Scripting (XSS)

Affects appleple a-blog cms Ver.3.1.x seriesSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium · fixed in 3.1.7 : update appleple a-blog cms Ver.3.1.x series when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.7, 3.0.29, 2.11.58 +2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
appleple inc. a-blog cms Ver.3.1.x seriesAffected
  • <3.1.7
  • <2.9.1
  • <2.10.50
  • <2.11.58
  • <3.0.29
Fixed in
  • 3.1.7
  • 2.9.1
  • 2.10.50
  • 2.11.58
  • 3.0.29

AI-suggested

1. Immediate upgrade: Organizations should promptly update a-blog cms installations to version 3.1.7 or later (or the corresponding fixed versions for other series) to remediate the vulnerability. 2. Privilege review: Conduct an audit of user roles and permissions within the CMS to ensure that contributor or higher privileges are only granted to trusted users. Limit the number of users with such privileges. 3. Input validation and output encoding: Implement additional web application firewall (WAF) rules to detect and block suspicious script injections targeting the CMS. 4. Content security policy (CSP): Deploy strict CSP headers to restrict the execution of unauthorized scripts in browsers accessing the CMS-managed sites. 5. User awareness: Educate contributors and administrators about the risks of XSS and safe content handling practices. 6. Monitoring and logging: Enable detailed logging of CMS activities and monitor for unusual behavior or injection attempts. 7. Segmentation: Isolate the CMS environment from critical internal networks to limit lateral movement if exploitation occurs. 8. Incident response readiness: Prepare to respond to potential incidents involving XSS exploitation, including session hijacking or website defacement.

Description

Cross-site scripting vulnerability exists in a-blog cms Ver.3.1.x series versions prior to Ver.3.1.7, Ver.3.0.x series versions prior to Ver.3.0.29, Ver.2.11.x series versions prior to Ver.2.11.58, Ver.2.10.x series versions prior to Ver.2.10.50, and Ver.2.9.0 and earlier versions. If this vulnerability is exploited, a user with a contributor or higher privilege may execute an arbitrary script on the web browser of the user who accessed the website using the product.

References

Community reviews

Loading reviews…