CVE-2024-25710: Apache Commons Compress · Infinite Loop
Affects Apache Commons CompressSource CVE Database V5
Not known to be exploited · CVSS 8.1 High · fixed in 1.26.0 : patch Apache Commons Compress soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.26.0
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Feb 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.commons/commons-compresspkg:maven/org.apache.commons/commons-compressOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-25710, European organizations should: 1) Immediately inventory all software and systems that include Apache Commons Compress versions 1.3 through 1.25.0. 2) Prioritize upgrading these components to version 1.26.0, which contains the fix for the infinite loop vulnerability. 3) For systems where immediate upgrade is not feasible, implement runtime monitoring to detect abnormal CPU usage or application hangs indicative of infinite loops. 4) Restrict local access to critical systems to trusted personnel only, reducing the risk of exploitation given the local attack vector. 5) Conduct thorough testing of updated components in staging environments to ensure compatibility and stability before production deployment. 6) Review internal security policies to detect and prevent insider threats that could exploit this vulnerability. 7) Maintain up-to-date backups and incident response plans to quickly recover from potential denial-of-service incidents. 8) Monitor security advisories and threat intelligence feeds for any emerging exploits targeting this vulnerability.
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.