CVE-2024-27919: envoyproxy envoy · Detection of Error Condition Without Action
Affects envoyproxy envoySource CVE Database V5
Not known to be exploited · 86% EPSS · CVSS 7.5 High.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 86.7% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubenvoyproxy/envoypkg:github/envoyproxy/envoyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading Envoy proxies to version 1.29.2 or later to fully remediate the vulnerability. If immediate upgrading is not feasible, downgrading to version 1.28.1 or earlier is a viable temporary measure. Additionally, disabling HTTP/2 protocol support for downstream connections can mitigate the risk, though this may impact performance or functionality. Network-level protections such as rate limiting and anomaly detection on HTTP/2 traffic can help detect and block abnormal CONTINUATION frame floods. Monitoring memory usage and setting resource limits on Envoy instances can reduce the impact of potential attacks. Organizations should audit their environments to identify all instances of Envoy running vulnerable versions and ensure patch management processes are updated to prevent regression vulnerabilities. Finally, integrating this vulnerability into incident response plans and threat hunting activities will improve readiness against exploitation attempts.
Description
Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.
References
- github.com/envoyproxy/envoy/security/advisories/GHSA-gghf-vfxp-799r (opens in a new tab)
- github.com/envoyproxy/envoy/commit/57a02565532c18eb9df972a3e8974be3ae59f2d5 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/05/3 (opens in a new tab)
- openwall.com/lists/oss-security/2024/04/03/16 (opens in a new tab)
- kb.cert.org/vuls/id/421644 (opens in a new tab)