CVE-2024-30261: nodejs undici · Improper Access Control
Affects nodejs undiciSource CVE Database V5
Not known to be exploited · CVSS 2.6 Low : upgrade to 5.28.4 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.28.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Apr 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade nodejs undici to 5.28.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmundicipkg:npm/undiciOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should promptly upgrade undici to version 5.28.4 or later, or 6.11.1 or later, to apply the official patches addressing this vulnerability. Beyond patching, developers should audit all uses of the fetch() API in their Node.js applications to verify correct and secure handling of the integrity option, ensuring it cannot be manipulated by untrusted inputs. Network-level protections such as TLS should be enforced to prevent man-in-the-middle attacks that could alter HTTP responses. Implementing strict Content Security Policies (CSP) and validating all external data sources can reduce the risk of accepting tampered data. Monitoring and logging HTTP request and response integrity checks can help detect anomalies. Security teams should also review supply chain dependencies to identify indirect usage of vulnerable undici versions. Finally, incorporate this vulnerability into threat modeling and incident response plans to prepare for potential exploitation scenarios.
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. An attacker can alter the `integrity` option passed to `fetch()`, allowing `fetch()` to accept requests as valid even if they have been tampered. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
References
- github.com/nodejs/undici/security/advisories/GHSA-9qxr-qj54-h672 (opens in a new tab)
- github.com/nodejs/undici/commit/2b39440bd9ded841c93dd72138f3b1763ae26055 (opens in a new tab)
- github.com/nodejs/undici/commit/d542b8cd39ec1ba303f038ea26098c3f355974f3 (opens in a new tab)
- hackerone.com/reports/2377760 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/P6Q4RGETHVYVHDIQGTJGU5AV6NJEI67E/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/HQVHWAS6WDXXIU7F72XI55VZ2LTZUB33/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/NC3V3HFZ5MOJRZDY5ZELL6REIRSPFROJ/ (opens in a new tab)
- security.netapp.com/advisory/ntap-20240905-0008/ (opens in a new tab)