CVE-2024-34347: hoppscotch · Command Injection
Affects hoppscotchSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 0.8.0 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade @hoppscotch/js-sandbox to 0.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npm@hoppscotch/js-sandboxpkg:npm/@hoppscotch/js-sandboxOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade hoppscotch CLI to version 0.8.0 or later immediately to apply the fix that removes the unsafe sandbox escape vectors. 2. Implement strict validation and code review processes for all pre-request scripts used in CI pipelines to ensure no untrusted or malicious code is executed. 3. Restrict execution of hoppscotch CLI and related testing tools to isolated environments with minimal privileges and network access to limit potential damage from exploitation. 4. Use containerization or sandboxing technologies external to Node.js vm to isolate test execution environments more securely. 5. Monitor CI/CD pipeline logs and system activity for unusual command execution or anomalies that could indicate exploitation attempts. 6. Educate developers and DevOps teams about the risks of running untrusted scripts and enforce policies to prevent unauthorized script injection. 7. If upgrading immediately is not possible, consider disabling or restricting the use of pre-request scripts in hoppscotch CLI until patched. 8. Maintain an inventory of affected versions in use and track updates from hoppscotch for any further advisories.
Description
@hoppscotch/cli is a CLI to run Hoppscotch Test Scripts in CI environments. Prior to 0.8.0, the @hoppscotch/js-sandbox package provides a Javascript sandbox that uses the Node.js vm module. However, the vm module is not safe for sandboxing untrusted Javascript code. This is because code inside the vm context can break out if it can get a hold of any reference to an object created outside of the vm. In the case of @hoppscotch/js-sandbox, multiple references to external objects are passed into the vm context to allow pre-request scripts interactions with environment variables and more. But this also allows the pre-request script to escape the sandbox. This vulnerability is fixed in 0.8.0.