CVE-2024-34502: WikibaseLexeme · n/a
Affects WikibaseLexemeSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 1.41.1 : patch WikibaseLexeme as a priority.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.41.1, 1.40.2, 1.39.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade wikimedia/extensions/WikibaseLexeme to 1.41.1, 1.40.2 or 1.39.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwikimedia/extensions/WikibaseLexemepkg:github/wikimedia/extensions/WikibaseLexemeOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2024-34502, European organizations should immediately upgrade MediaWiki installations to versions 1.39.6, 1.40.2, or 1.41.1 and later, where the vulnerability is patched. If immediate upgrading is not feasible, administrators should restrict access to the Special:MergeLexemes page by implementing strict access controls, such as IP whitelisting or authentication requirements, to limit exposure. Additionally, web application firewalls (WAFs) can be configured to block suspicious requests attempting to access merge functionality without proper tokens or using GET methods. Monitoring logs for unusual merge activity or unexpected edits can help detect exploitation attempts early. Organizations should also review and harden CSRF protections in their MediaWiki configurations and consider disabling the WikibaseLexeme extension if it is not essential. Regular security audits and vulnerability scanning focused on MediaWiki deployments will help identify and remediate similar issues proactively.
Description
An issue was discovered in WikibaseLexeme in MediaWiki before 1.39.6, 1.40.x before 1.40.2, and 1.41.x before 1.41.1. Loading Special:MergeLexemes will (attempt to) make an edit that merges the from-id to the to-id, even if the request was not a POST request, and even if it does not contain an edit token.
References
- phabricator.wikimedia.org/T357101 (opens in a new tab)
- gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseLexeme/+/1013359 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY/ (opens in a new tab)