Skip to main content
CVE-2024-39573VulnerabilityPublished Updated

CVE-2024-39573: Apache HTTP Server · Improper Input Validation

Affects Apache HTTP ServerSource CVE Database V5

0

Not known to be exploited · 35% EPSS · CVSS 7.5 High · fixed in 2.4.60 : patch Apache HTTP Server soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
35.4% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.60
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache HTTP ServerAffected
  • =2.4.0
Fixed in–

AI-suggested

1. Upgrade Apache HTTP Server to version 2.4.60 or later immediately to apply the official fix. 2. Conduct a thorough audit of all mod_rewrite configurations to identify and remove or secure any unsafe RewriteRules that could redirect requests to mod_proxy. 3. Implement strict network segmentation and firewall rules to limit the web server's ability to initiate outbound requests to internal services, reducing SSRF impact. 4. Monitor web server logs for unusual or unexpected proxy requests that could indicate exploitation attempts. 5. Employ web application firewalls (WAFs) with rules designed to detect and block SSRF patterns related to mod_rewrite misuse. 6. Regularly review and update security policies related to web server configurations and internal network access controls. 7. Educate system administrators and developers about the risks of SSRF and secure URL rewriting practices.

Description

Potential SSRF in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows an attacker to cause unsafe RewriteRules to unexpectedly setup URL's to be handled by mod_proxy. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

References

Community reviews

Loading reviews…