Skip to main content
CVE-2024-41628VulnerabilityPublished Updated

CVE-2024-41628: ClusterControl · n/a

Affects ClusterControlSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High · fixed in 2.1.0-9780 : patch ClusterControl soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
6.5% chance of exploitation in 30 days – higher than 93% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.0-9780, 2.0.0-9779, 1.9.8-9778
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jul 2024

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade severalnines/ClusterControl to 2.1.0-9780, 2.0.0-9779 or 1.9.8-9778.

Affected software

ProductAffectedFixed in
GitHubseveralnines/ClusterControlpkg:github/severalnines/ClusterControlOther threatsAffected
  • <1.9.8-9778
  • <2.0.0-9779
  • <2.1.0-9780
Fixed in
  • 1.9.8-9778
  • 2.0.0-9779
  • 2.1.0-9780

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Severalnines Cluster Control to versions 1.9.8-9778 or later, 2.0.0-9779 or later, or 2.1.0-9780 or later to remediate this vulnerability. Patch status is confirmed by the version numbers indicating fixed releases. No alternative mitigations or temporary fixes are documented.

Description

Directory Traversal vulnerability in Severalnines Cluster Control 1.9.8 before 1.9.8-9778, 2.0.0 before 2.0.0-9779, and 2.1.0 before 2.1.0-9780 allows a remote attacker to include and display file content in an HTTP request via the CMON API.

References

Community reviews

Loading reviews…