CVE-2024-45598: cacti · Path Traversal
Affects cactiSource GCVE Database
Not known to be exploited · CVSS 6.0 Medium : upgrade to 1.2.29 when convenient.
Data as of 30 Oct 2026, 00:26 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 6.0 |
|---|
- Patch
- Available – fixed in 1.2.29
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Jan 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade cacti to 1.2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cacti cacti | Affected
| Fixed in
|
AI-suggested
Upgrade Cacti to version 1.2.29 or later, where this path traversal vulnerability is fixed. No additional mitigation steps are indicated by the vendor advisory.
Description
CVE-2024-45598 is a path traversal vulnerability in Cacti versions prior to 1.2.29. An administrator can set the 'Poller Standard Error Log Path' to a local file on the server, which can then be viewed via the web UI's Logs tab, potentially exposing sensitive file contents. This issue is fixed in version 1.2.29.