Skip to main content
VulnerabilityPublished Updated

CVE-2025-24367: cacti · Improper Neutralization of Line Delimiters

Affects cactiSource GCVE Database

0
Compare

Public exploit available (Metasploit) · CVSS 8.7 High · fixed in 1.2.29 : patch cacti as a priority.

Data as of 30 Oct 2026, 00:33 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.7
Patch
Available – fixed in 1.2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Cacti cactiAffected
  • <=1.2.28
Fixed in–

AI-suggested

Upgrade Cacti to version 1.2.29 or later, where this vulnerability is fixed. No other mitigations are specified by the vendor advisory. Since this is an authenticated vulnerability, restricting user access and monitoring for suspicious activity may reduce risk but do not replace patching.

Description

CVE-2025-24367 is a vulnerability in Cacti, an open source performance and fault management framework. Authenticated users can exploit graph creation and template features to upload arbitrary PHP scripts to the web root, enabling remote code execution. This flaw is fixed in version 1.2.29.

References

Community reviews

Loading reviews…