CVE-2024-46910: Apache Atlas · Basic XSS
Affects Apache AtlasSource CVE Database V5
Not known to be exploited · CVSS 7.1 High · fixed in 2.4.0 : patch Apache Atlas soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.atlas/atlaspkg:maven/org.apache.atlas/atlasOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately assess their Apache Atlas deployments to identify versions 2.3.0 and earlier in use. The primary mitigation is to upgrade to Apache Atlas version 2.4.0 or later, which contains the fix for this XSS vulnerability. Until upgrades can be performed, organizations should restrict access to Apache Atlas interfaces to trusted users only and enforce strong authentication and session management controls to reduce the risk of compromised credentials. Implement web application firewalls (WAFs) with rules to detect and block XSS payloads targeting Apache Atlas. Conduct regular security audits and input validation reviews on custom integrations with Atlas to ensure no additional injection vectors exist. Educate users about phishing and credential security to minimize the risk of account compromise. Monitor logs for suspicious activity indicative of attempted XSS exploitation or user impersonation. Finally, apply the principle of least privilege to limit the impact of any compromised accounts.
Description
An authenticated user can perform XSS and potentially impersonate another user. This issue affects Apache Atlas versions 2.3.0 and earlier. Users are recommended to upgrade to version 2.4.0, which fixes the issue.