Skip to main content
CVE-2024-47210VulnerabilityPublished Updated

CVE-2024-47210: Gladys · n/a

Affects GladysSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 4.45.1 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.45.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gladysassistant/Gladys to 4.45.1.

Affected software

ProductAffectedFixed in
GitHubgladysassistant/Gladyspkg:github/gladysassistant/GladysOther threatsAffected
  • <4.45.1
Fixed in
  • 4.45.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade Gladys Assistant to version 4.45.1 or later where the issue is patched. If upgrading is not immediately possible, implement strict network segmentation and access controls to restrict authenticated user access to trusted individuals only. Review and harden API endpoint permissions, ensuring that role changes cannot be performed by users on their own accounts without proper authorization checks. Employ application-layer firewalls or API gateways to monitor and block suspicious requests attempting to modify user roles. Conduct regular audits of user roles and permissions to detect unauthorized changes. Additionally, enable detailed logging and alerting on user role modifications to facilitate rapid detection and response. Educate users about the risks of privilege escalation and enforce strong authentication mechanisms to reduce the risk of compromised accounts being used to exploit this vulnerability.

Description

Gladys Assistant before 4.45.1 allows Privilege Escalation (a user changing their own role) because req.body.role can be used in updateMySelf in server/api/controllers/user.controller.js.

References

Community reviews

Loading reviews…