Skip to main content
VulnerabilityPublished Updated

CVE-2024-51915: LiteSpeed Cache (WordPress plugin) · Cross-site Scripting

Affects LiteSpeed Cache (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 6.5.3 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.5.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade LiteSpeed Cache (WordPress plugin) to 6.5.3.

Affected software

ProductAffectedFixed in
LiteSpeed TechnologiesLiteSpeed CacheAffected
  • <6.5.3
Fixed in
  • 6.5.3

AI-suggested

If you cannot patch yet, users should exercise caution with input handling and consider applying any recommended temporary mitigations from the vendor. Monitoring for updates from LiteSpeed Technologies is advised.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Stored XSS.This issue affects LiteSpeed Cache: from n/a through <= 6.5.2.

References

Community reviews

Loading reviews…