CVE-2024-52387: Master Addons for Elementor (WordPress plugin) · Cross-site Scripting
Affects Master Addons for Elementor (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 5.9 Medium : upgrade to 2.1.0 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Master Addons for Elementor (WordPress plugin) to 2.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Liton ArefinMaster Addons for Elementor | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict access to the plugin to trusted users only and monitor for suspicious activity related to input handling. Avoid exposing the vulnerable plugin to untrusted users. Follow updates from the vendor for any released patches or official mitigations.
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Liton Arefin Master Addons for Elementor master-addons allows Stored XSS.This issue affects Master Addons for Elementor: from n/a through <= 2.0.9.9.4.