Skip to main content
VulnerabilityPublished Updated

CVE-2024-58239: Linux kernel · tls: stop recv() if initial process_rx_list gave us non-DATA

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.2 High · fixed in 5.4.0-1126.136~18.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:38 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.4.0-1126.136~18.04.1, 5.4.0-1131.138~18.04.1, 5.4.0-1130.139~18.04.1 +54
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-azure-6.11pkg:deb/ubuntu/linux-azure-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1008.8~24.04.1 – 6.11.0-1018.18~24.04.1
7 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-gcp-6.11pkg:deb/ubuntu/linux-gcp-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1006.6~24.04.2 – 6.11.0-1017.17~24.04.1
7 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-hwe-6.11pkg:deb/ubuntu/linux-hwe-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-17.17~24.04.2 – 6.11.0-29.29~24.04.1
8 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-intelpkg:deb/ubuntu/linux-intel?arch=source&distro=nobleOther threatsAffected
  • =6.8.0-1005.12
  • =6.8.0-1006.13
  • =6.8.0-1007.14
Fixed in–
Ubuntu 24.04 LTSlinux-lowlatency-hwe-6.11pkg:deb/ubuntu/linux-lowlatency-hwe-6.11?arch=source&distro=nobleOther threatsAffected
  • 6.11.0-1009.10~24.04.1 – 6.11.0-1016.17~24.04.1
7 affected builds
Fixed in–
Ubuntu 24.04 LTSlinux-oem-6.8pkg:deb/ubuntu/linux-oem-6.8?arch=source&distro=nobleOther threatsAffected
  • 6.8.0-1003.3 – 6.8.0-1032.32
26 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in Linux kernel versions 5.4.0-1126.136 and later related releases. Users and administrators should upgrade affected Linux kernel versions to these fixed releases to remediate the vulnerability. Since this is a kernel-level issue, applying the official kernel updates is the recommended and effective mitigation.

Description

CVE-2024-58239 is a high-severity vulnerability in the Linux kernel's TLS implementation where the recv() function mishandles non-DATA records in the process_rx_list. This can cause improper merging of records leading to potential denial of service. The issue has been fixed in multiple Linux kernel versions starting from 5.4.0-1126.136 and related releases.

References

Community reviews

Loading reviews…