CVE-2024-8425: WooCommerce Ultimate Gift Card (WordPress plugin) · Unrestricted File Upload
Affects WooCommerce Ultimate Gift Card (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 9.8 Critical.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 4.0% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Feb 2025
Detectable: evidence found.
nuclei template: WooCommerce Ultimate Gift Card ≤ 2.6.0 - Arbitrary File Upload
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| WP Swings WooCommerce Ultimate Gift Card | Affected
| Fixed in– |
AI-suggested
Upgrade the WooCommerce Ultimate Gift Card plugin to version 2.9.3 or later, where this vulnerability has been patched. If upgrading immediately is not possible, restrict file upload permissions and monitor for suspicious activity, but note that the definitive remediation is applying the official patch in version 2.9.3.
Description
The WooCommerce Ultimate Gift Card plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'mwb_wgm_preview_mail' and 'mwb_wgm_woocommerce_add_cart_item_data' functions in all versions up to, and including, 2.9.2. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible. Please note that this may have been patched on an older version than 2.9.2, however, we do not have access to older versions of the software to confirm when the patch was added. The only patched version we have confirmed is 2.9.3.