CVE-2024-9098: lunary-ai/lunary · Incorrect Authorization
Affects lunary-ai/lunarySource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 1.4.30 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.30
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade lunary-ai/lunary to 1.4.30.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade lunary-ai/lunary to version 1.4.30 or later where this vulnerability is fixed. Until patching, restrict admin privileges to only trusted personnel and monitor user creation activities closely for suspicious billing role assignments. Implement additional internal controls such as multi-factor approval workflows for billing permission grants. Audit logs should be reviewed regularly to detect unauthorized privilege escalations. Network segmentation and role-based access controls should be enforced to limit the blast radius of compromised admin accounts. Security teams should also educate admins about the risk of improper user invitations and enforce strict policies on role assignments. Finally, integrate vulnerability scanning and continuous monitoring to detect any attempts to exploit this flaw.
Description
In lunary-ai/lunary before version 1.4.30, a privilege escalation vulnerability exists where admins can invite new members with billing permissions, thereby gaining unauthorized access to billing resources. This issue arises because the user creation endpoint does not restrict admins from inviting users with billing roles. As a result, admins can circumvent the intended access control, posing a risk to the organization's financial resources.