CVE-2025-10016: Sparkle · Incorrect Authorization
Affects SparkleSource CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 2.7.2 : patch Sparkle soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.7.2
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Sparkle Project Sparkle | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify if their macOS applications utilize the Sparkle framework and identify the version in use. Upgrading to Sparkle version 2.7.2 or later, where the vulnerability is fixed, is the primary and most effective mitigation. For environments where immediate upgrade is not feasible, organizations should restrict local access to macOS systems, enforce strict user account controls, and monitor for suspicious activity related to the Autoupdate daemon. Application developers should audit their integration of Sparkle to ensure no insecure usage patterns exist, such as spawning the Autoupdate daemon manually without proper authorization checks. Additionally, implementing endpoint detection and response (EDR) tools that can detect anomalous privilege escalation attempts and monitoring system authorization dialogs for tampering can help detect exploitation attempts. Regular security training to raise awareness about local privilege escalation risks and limiting physical or remote local access to trusted users further reduces exposure.
Description
The Sparkle framework includes a helper tool Autoupdate. Due to lack of authentication of connecting clients a local unprivileged attacker can request installation of crafted malicious PKG file by racing to connect to the daemon when other app spawns it as root. This results in local privilege escalation to root privileges. It is worth noting that it is possible to spawn Autopudate manually via Installer XPC service. However this requires the victim to enter credentials upon system authorization dialog creation that can be modified by the attacker. This issue was fixed in version 2.7.2