CVE-2025-10061: MongoDB Server · Improper Input Validation
Affects MongoDB ServerSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MongoDB Inc MongoDB Server | Affected
| Fixed in– |
AI-suggested
European organizations should promptly upgrade affected MongoDB Server instances to the fixed versions: 6.0.25 or later, 7.0.22 or later, 8.0.12 or later, and 8.1.2 or later. Until patches are applied, organizations should restrict database access strictly to trusted and authenticated users, minimizing the attack surface. Implement network-level controls such as IP whitelisting and VPNs to limit exposure of MongoDB endpoints. Monitor logs for unusual or malformed $group aggregation queries that could indicate attempted exploitation. Employ rate limiting on query submissions to reduce the risk of repeated triggering of the crash. Additionally, review and harden application-level input validation to prevent injection of malicious aggregation parameters. Regularly test backup and recovery procedures to ensure rapid restoration in case of service disruption. Finally, maintain up-to-date inventory of MongoDB deployments and versions to prioritize patching efforts effectively.
Description
An authorized user can cause a crash in the MongoDB Server through a specially crafted $group query. This vulnerability is related to the incorrect handling of certain accumulator functions when additional parameters are specified within the $group operation. This vulnerability could lead to denial of service if triggered repeatedly. This issue affects MongoDB Server v6.0 versions prior to 6.0.25, MongoDB Server v7.0 versions prior to 7.0.22, MongoDB Server v8.0 versions prior to 8.0.12 and MongoDB Server v8.1 versions prior to 8.1.2