CVE-2025-10861: Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin) · Server-Side Request Forgery (SSRF)
Affects Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 2.1.4 : patch Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers (WordPress plugin) soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.1.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| roxnor Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers | Affected
| Fixed in– |
AI-suggested
The vulnerability was partially patched in version 2.1.4 of the plugin. Until a full patch is available, consider restricting access to the plugin's functionality or implementing network-level controls to limit the server's ability to make arbitrary outbound requests.
Description
The Popup builder with Gamification, Multi-Step Popups, Page-Level Targeting, and WooCommerce Triggers plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.1.4. This is due to insufficient validation on the URLs supplied via the URL parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services, as well as conduct network reconnaissance. The vulnerability was partially patched in version 2.1.4.
References
- wordfence.com/threat-intel/vulnerabilities/id/5f4767b5-5dd6-4a2a-b44a-5297432286b1?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/popup-builder-block/tags/2.1.2/includes/Routes/FetchDemo.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3369146/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3379308/ (opens in a new tab)