Skip to main content
CVE-2025-11021VulnerabilityPublished Updated

CVE-2025-11021: Red Hat Enterprise Linux 10 · Out-of-bounds Read

Affects Red Hat Enterprise Linux 10Source CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat Enterprise Linux 10 to 10.0.7 or 9.6.3 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.0.7, 9.6.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Red Hat Enterprise Linux 10 to 10.0.7 or 9.6.3.

Affected software

ProductAffectedFixed in
Red Hat Red Hat Enterprise Linux 10Affected
  • =0
  • >=9.0 <9.6.3
  • >=10.0 <10.0.7
Fixed in
  • 9.6.3
  • 10.0.7

AI-suggested

Red Hat has released official security updates that fix this vulnerability in affected versions of libsoup and libsoup3 packages for Red Hat Enterprise Linux 9 and 10. Users should apply these updates promptly. Refer to Red Hat advisories RHSA-2025:18183 and RHSA-2025:19713 and the update instructions at https://access.redhat.com/articles/11258 for detailed remediation steps. No additional mitigations are indicated by the vendor advisory.

Description

A flaw was found in the cookie date handling logic of the libsoup HTTP library, widely used by GNOME and other applications for web communication. When processing cookies with specially crafted expiration dates, the library may perform an out-of-bounds memory read. This flaw could result in unintended disclosure of memory contents, potentially exposing sensitive information from the process using libsoup.

References

Community reviews

Loading reviews…