Skip to main content
CVE-2025-12377VulnerabilityPublished Updated

CVE-2025-12377: Envira Gallery (WordPress plugin) · Missing Authorization

Affects Envira Gallery (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 1.12.0 : update Envira Gallery (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.12.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
smub Envira Gallery – Image Photo Gallery, Albums, Video Gallery, Slideshows & MoreAffected
  • =0
Fixed in–

AI-suggested

The vulnerability was partially patched in version 1.12.0, so updating to the latest plugin version is recommended if a newer version beyond 1.12.0 is available. Until a full fix is confirmed, restrict Author-level access to trusted users only to reduce risk.

Description

The Gallery Plugin for WordPress – Envira Photo Gallery plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 1.12.0. This makes it possible for authenticated attackers, with Author-level access and above, to perform multiple actions, such as removing images from arbitrary galleries. The vulnerability was partially patched in version 1.12.0.

References

Community reviews

Loading reviews…