Skip to main content
CVE-2025-12499VulnerabilityPublished Updated

CVE-2025-12499: Rich Showcase for Google Reviews (WordPress plugin) · Cross-site Scripting

Affects Rich Showcase for Google Reviews (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 6.6.2 : patch Rich Showcase for Google Reviews (WordPress plugin) soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
widgetpack Rich Showcase for Google ReviewsAffected
  • =0
Fixed in–

AI-suggested

The vulnerability was partially patched in version 6.6.2, but versions up to 6.8 remain vulnerable. Users should verify with the vendor or plugin maintainers for updated patches or security advisories. Until a full fix is available, consider disabling or removing the plugin or restricting access to affected pages to trusted users only. Monitor vendor channels for official updates.

Description

The Rich Shortcodes for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the contents of a Google Review in all versions up to, and including, 6.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability was partially patched in version 6.6.2.

References

Community reviews

Loading reviews…