CVE-2025-12630: Upload.am (WordPress plugin) · Missing Authorization
Affects Upload.am (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 4.9 Medium · fixed in 1.0.1 : update Upload.am (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Upload.am | Affected
| Fixed in– |
AI-suggested
1. Immediately update the Upload.am WordPress plugin to version 1.0.1 or later once available to ensure the missing authorization check is implemented. 2. Audit all WordPress user roles and permissions to ensure that contributor accounts are assigned only to trusted users and that their privileges are minimized. 3. Implement strict role-based access control (RBAC) policies to limit the number of users with contributor or higher privileges. 4. Monitor AJAX request logs for unusual access patterns or attempts to access site options by contributor accounts. 5. Employ Web Application Firewalls (WAFs) with custom rules to detect and block unauthorized AJAX requests targeting the vulnerable endpoints. 6. Regularly review and harden WordPress security configurations, including disabling unnecessary plugins and limiting plugin installations to trusted sources. 7. Educate site administrators and content contributors about the risks of privilege misuse and encourage reporting of suspicious activity. 8. Consider implementing multi-factor authentication (MFA) for all privileged accounts to reduce the risk of compromised credentials being exploited.
Description
The Upload.am WordPress plugin before 1.0.1 is vulnerable to arbitrary option disclosure due to a missing capability check on its AJAX request handler, allowing users such as contributor to view site options.