Skip to main content
VulnerabilityPublished

CVE-2025-12740: Google Cloud Looker · Improper Input Validation

Affects Google Cloud LookerSource CVE Database V5

0

Not known to be exploited · CVSS 7.7 High.

Data as of 26 Oct 2026, 09:08 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:Red

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Google Cloud LookerAffected
  • =0
Fixed in–

AI-suggested

European organizations should immediately verify if they operate Self-hosted Looker instances with IBM DB2 drivers and upgrade to the patched versions listed (25.0.93+, 25.6.84+, 25.12.42+, 25.14.50+, or 25.16.44+). Restrict Developer role assignments strictly to trusted personnel and implement strong authentication and monitoring for these accounts. Employ network segmentation to limit Looker server access and database connectivity. Enable detailed logging and alerting on LookML changes and database connection creations to detect suspicious activity. Conduct regular audits of user roles and permissions within Looker. Additionally, consider implementing runtime application self-protection (RASP) or web application firewalls (WAF) that can detect and block anomalous command execution attempts. Finally, ensure incident response plans include scenarios for Looker compromise and conduct tabletop exercises to prepare for potential exploitation.

Description

CVE-2025-12740 is a high-severity vulnerability in Google Cloud Looker affecting both Looker-hosted and Self-hosted instances. It arises from improper input validation (CWE-20) in the IBM DB2 driver parameters, allowing a user with Developer role privileges to craft malicious LookML that triggers execution of arbitrary commands. While Looker-hosted instances have been automatically mitigated, Self-hosted deployments require urgent upgrades to patched versions (25.0.93+, 25.6.84+, 25.12.42+, 25.14.

References

Community reviews

Loading reviews…