CVE-2025-12818: PostgreSQL · Integer Overflow or Wraparound
Affects PostgreSQLSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium · fixed in 18.1 : update PostgreSQL when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 18.1, 17.7, 16.11 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. 2. Implement strict input validation and sanitization on all application inputs that interact with libpq to prevent malformed data from triggering the overflow. 3. Employ network-level controls such as firewalls and intrusion detection/prevention systems to monitor and restrict suspicious traffic targeting PostgreSQL services. 4. Conduct thorough testing of applications using libpq to identify any abnormal crashes or memory issues that could indicate exploitation attempts. 5. Maintain up-to-date backups and disaster recovery plans to quickly restore services in case of denial-of-service incidents. 6. Monitor PostgreSQL and system logs for unusual segmentation faults or crashes that could signal exploitation attempts. 7. Limit exposure of PostgreSQL client interfaces to trusted networks and authenticated users where possible to reduce attack vectors. 8. Engage in proactive threat intelligence sharing within industry sectors to stay informed about emerging exploits related to this vulnerability.
Description
CVE-2025-12818 is an integer overflow or wraparound vulnerability in the PostgreSQL libpq client library that can cause undersized memory allocations and out-of-bounds writes, leading to application crashes via segmentation faults. It affects multiple PostgreSQL versions prior to 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23. Exploitation requires no authentication or user interaction but has a high attack complexity due to the need for crafted input from an application input provider or network peer. The vulnerability impacts availability by causing application crashes but does not affect confidentiality or integrity.