CVE-2025-13523: Mattermost Confluence Plugin · Cross-site Scripting
Affects Mattermost Confluence PluginSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 1.7.0 soon.
Data as of 26 Oct 2026, 12:54 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.7.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Mattermost Confluence Plugin to 1.7.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MattermostMattermost Confluence Plugin | Affected
| Fixed in
|
GitHubMattermost Confluence Pluginpkg:github/Mattermost Confluence PluginOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately restrict or monitor the sharing of OAuth2 connection links within the organization to prevent malicious link propagation.
- Implement strict input validation and sanitization on user display names at the application level, if possible, as a temporary control.
- Educate users to be cautious about clicking on unexpected or suspicious OAuth2 links, especially those received from internal users.
- Apply network-level protections such as Content Security Policy (CSP) headers to limit the impact of injected scripts.
- Monitor logs and user activity for unusual behavior indicative of exploitation attempts, such as unexpected OAuth2 link visits or changes in display names.
- Coordinate with Mattermost and Atlassian to obtain and deploy the official patch for the Confluence plugin version 1.7.0 or later as soon as it becomes available.
- Review and tighten Confluence user permissions to limit the ability to set or change display names arbitrarily.
- Consider isolating or sandboxing the plugin environment to reduce the scope of potential XSS impact.
Description
Mattermost Confluence plugin version <1.7.0 fails to properly escape user-controlled display names in HTML template rendering which allows authenticated Confluence users with malicious display names to execute arbitrary JavaScript in victim browsers via sending a specially crafted OAuth2 connection link that, when visited, renders the attacker's display name without proper sanitization. Mattermost Advisory ID: MMSA-2025-00557